Resource Menu

posted by Sebastien Jourdain at Jul 26, 2006 10:16 AM
Happy to ear that...

In fact the problem was about the file management in LibreSource, due to the invalide path set to store tmp files. The system was unable to store and retreive the uploaded file that was the bootstrap.xml file.

artenum Team

posted by Guest at Jul 25, 2006 6:32 PM
Re-reading through the steps below fixed my problem. Thanks.

I changed the file C:\LibreSource\LibreSource\

to: libresource.distributedFilesystem=C:/LibreSource/work/files

(Using the forward slashes.)

Then I ran the config.bat located in the libresource install directory.

This fixed the issue with not loading the bootstrap file.

Thanks for your prompt attention to this issue.

posted by Guest at Jul 25, 2006 6:15 PM
Thanks for your reply.

That answers most of my questions.

I do, however, have one last issue and it is the most critical. I described the problem in the posting below. I have tried to load the bootstrap file from multiple machines running windows xp and I get an error that it fails to find the file (the bootstrap.xml file). What can I do to load the bootstrap file? Is there a way to manually load the file. It appears that this is an issue with the way that the file, and directory are being being selected; the path isn't found.

posted by Sebastien Jourdain at Jul 25, 2006 11:03 AM
Hello Robert,

First the file should be updated in order to specify the right working path for the search engine and the tmp files.

When you have set the right properties, you have to update the ear file. For that ant will do it for you. There is 2 ways.

  • If you are using libresource from the installer, this should have been done by the installer but if you change your mind, you can but you will have to call the configure script available in your libresource installation directory.
  • If you are using LibreSource from the source package, just call ant or ant deploy . Don't forget that your $JONAS_ROOT system property must be set...
Otherwise to explain a bite why you should put twice back-slash instead of one, this is because the back-slash character is the java escape character. A simpler way is to use on any OS the / as path separator.

For example: C:/LibreSource/tmp/file

> Also, is there somewhere that I can set the $dburl, $dbuser and $dbpassword other than in the C:\LibreSource\JOnAS\conf\

I don't realy get your question, but those informations are needed for jonas in order to access to the LibreSource database.

This database should run over Postgres and must be available first.

And one last question; does libresource run on jboss?

Not yet, but it could run on JBoss if some XDocklet comment where added for JBoss in the source code so the application descriptor could be generated for JBoss.

I hope that I answer at your questions...

Artenum Team

posted by Sebastien Jourdain at Jul 25, 2006 10:46 AM

I am having an issue with the bootstrap after installation on windows xp. This is the path that I am trying to upload the bootstrap:


and this is the error message I am getting:

Unexpected error - Go Back The system cannot find the path specified The system cannot find the path specified

This is the log from the server log:

Mon Jul 24 14:53:24 MDT 2006 : ERROR : The system cannot find the path specified

Is there a setup issue I need, or how can I get it to recognize the file in windows?

Do I need to change the file

It says:

# WARNING, if the following properties contains path with '\' character, change them to '\\'
#Example : C:\\LibreSource\\work\\index >> C:\\LibreSource\\work\\index\LibreSource\\work\\index

I don't know if I should change it to c:\\LibreSource\\work\\index or leave it as it was as c:\LibreSource\\work\\index

Also, is there somewhere that I can set the $dburl, $dbuser and $dbpassword other than in the C:\LibreSource\JOnAS\conf\

And one last question; does libresource run on jboss?

This question was posted by mail by Robert Young.

posted by Sebastien Jourdain at Jan 11, 2006 12:22 PM
Hello, the configuration file is needed to update the EAR file… After changing it, you should call ant in order to package a new EAR file with the rights properties. You don't need to recompile the whole application, it's just the intergration of your properties inside the XML descriptor of the EJB application.

Moreover, as you are working on Windows, you should take care of the security of your shared filesystem between Jonas and postgres in order to allow each other to write and read on that area.


Artenum Team…

posted by Guest at Jan 11, 2006 12:22 PM
Hi !

I've just finish to install LibreSource on a Win2K system. I've successfull started the Jonas server with LibreSource. But when I try to bootstrap the ressource file, I get this error : Le volume ne contient pas de système de fichiers connu. Vérifiez si tous les pilotes de système de fichiers nécessaires sont chargés et si le volume n'est pas endommagé

I think it's a problem related with the configuration files that specify some directories. I've set it (ls-config;properties), but I don't know where should I put this configuration file in the filedir of Jonas ?