Resource Menu

posted by Sebastien Jourdain at Sep 7, 2007 1:56 AM
Check if on your synchronizer all the workspace have a date of synchronisation. The pb, could come from that.

Another things, is that when you export you project you should be able to see on which resource the XML file stops. (uri)

For cache reason it might not be that one, but I suppose it's a resource below that one or a sibling. So with few check you should be able to get the information...

Normally, such error should generate server error.

posted by Rüdiger Lincke at Sep 3, 2007 11:28 PM
After further investigation I think I know the following:
  • first IE7 does cause some problems, in particular with listing children.
  • I have some inconsistency in one resource of my database causing it to break the xml export. Also the template generation from this resource does not work. I used a different resource.
For now everything works fine, when I use Firefox (dont know about other browers).

Any idea if there is a way to find out which resources are causing the problem, so that I can remove or fix them? In my case, I just know the project being problematic, but I do not have the time to export each single resource to find out, which one it is. Yet I assume it might be some synchronizer.

posted by Rüdiger Lincke at Sep 3, 2007 9:43 PM
Yes, and I feel kind of stupid, that I did not recognize it earlier, that the problem described latest does not occur with Mozilla Firefox. I will check, how it is with the export and import...

I think its not a problem with the database or LibreSource, its my browser.

I will see, and come back with more information, when I have it.

posted by Sebastien Jourdain at Aug 30, 2007 10:53 AM
Are you using IE ?
posted by Rüdiger Lincke at Aug 30, 2007 10:50 AM
Maybe I did a mistake when migrating the data.

When I try to view the children of any resource, but the root /, it duplicates the /projects string, and this fails.

e.g., instead of .../projects/courses?action=children, it shows .../projects/projects/coureses?action=children

Which fails of course.

Any idea, where the related data is stored in the database, so that I could fix it there.

posted by Sebastien Jourdain at Aug 30, 2007 10:43 AM
The setting that I was talking about was the jonas.service.jtm.timeout. So as you said is not the problem.

As I understand the problem is related to a specific resource in your subtree. Normally you should see error on the standard output. (not necessary on the jonas logs.) Did you manage to make a list children as a huge tree of the thing that you tried to export ? First of all you should check that all the previous resource could be seen on the web. For the database corruption, I don't believe in that.

Find out the node that is sick. And tel me which one with the std output as log.

posted by Rüdiger Lincke at Aug 30, 2007 10:29 AM

with extending the time of transaction timeout in jonas, do you mean the setting: jonas.service.jtm.timeout in the file?

It has a default value of 3600 seconds, which is about 1 hour. I guess this should be enough, and the export takes just a few minutes. Or am I looking at the wrong setting?

I do not find any exception in the jonas or libresource logs (JONAS/logs folder).

I export as root, and even locally to do it fast, but the file is not complete.

The problem seems to be related to the resources I am trying to export. I tried it with some other parts, and there it works well. Maybe there is something wrong with the data in the database, causing the export to be incomplete.

Is there a way to validate my database, to find out if there is something invalid, causing trouble?

Actually, the reason, why I try to export and import is, the template creating of that resource does not work, thats propably connected.

Well, after further investigation, I found that somehow my database is corrupt, showing:

The resource does not exist ls:// :: "/projects/courses/dab702" has no child "null"

I dont know, if this is the reason or a consequence of my doings. I will restore it to a previous state, and check then, if the problem still occur.

posted by Rüdiger Lincke at Aug 29, 2007 4:28 PM
great, thank you, I will try that out tomorrow
posted by Sebastien Jourdain at Aug 29, 2007 4:17 PM
Here are the known way to handle it:
  • Check for server exception (Error in exporter or in data on the server -> Need to fix exporter/data)
  • Do the export as Root (Faster access to nodes)
  • Extend the time of transaction timeout in jonas (Timeout config)
posted by Rüdiger Lincke at Aug 29, 2007 4:02 PM
Taking a closer look, it almost looks like that the export did not complete.

I tried it from different computers, always same result.

posted by Rüdiger Lincke at Aug 29, 2007 3:54 PM

I am exporting a resource tree using the ?action=xml command. When I try to import this at another location, I get an error, stating, that an element is not closed.

When I check the .xml file, I find, that there are some kernel:node elements not closed. I count in my case 43 <kernel:node ...> openings, and only 38 </kernel:node> close elements. Thats 5 short.

Also the <libresource:libresource-dump...> element is not closed.

Is this a known bug? Any idea what I can do?

Thank you, Rüdiger